summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Westphal <fw@strlen.de>2014-04-10 12:27:07 +0200
committerFlorian Westphal <fw@strlen.de>2014-04-10 12:27:07 +0200
commit81e268ee036a9faef2193d807b77108782ac0cde (patch)
tree9762ea0036b6c08dd54918eebebc77cc64885c5e /configure.ac
parent21966fa7e242c58c2d581c406af4e7978c981465 (diff)
build: drop AC_FUNC_MALLOC/REALLOC
Two issues with these: 1. They compile & run a test program, which won't work when cross-compiling 2. When libnftnl has just been installed and is not (yet) in linker path, the test fails since loader won't find libnftnl. In that case configure will succeed without obvious errors, but config.h re-defines malloc/realloc with rpl_ prefix, which then results in a linker error ("undefined reference to `rpl_realloc'") on 'make'. These macros are only useful to check that malloc(0) returns non-NULL and that realloc(NULL, ... works. For nftables the former is irrelevant and the latter a safe assumption, so lets just remove them. Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b91bbac1..6a5e4ce6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,8 +88,6 @@ AC_TYPE_UINT32_T
AC_TYPE_UINT64_T
# Checks for library functions.
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
AC_CHECK_FUNCS([memmove memset strchr strdup strerror strtoull])
AC_CONFIG_FILES([Makefile Makefile.defs Makefile.rules])