summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2014-12-14 20:59:16 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2014-12-15 13:07:51 +0100
commitad23ef1cd507e3723f5a52ab8cae5e6830755725 (patch)
treeb3ab2490631cec4e1e9d32c8e42c1e2f7c43070e /configure.ac
parent23c53ae90cf8117cb383d93299de52b4e854384f (diff)
build: restore --disable-debug
Fix fallout from the automake conversion. Display after configuration if it is enabled or not. Reported-by: Steven Barth <cyrus@openwrt.org> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1525ac4d..b55b2b1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,9 +24,10 @@ AC_DEFINE([_STDC_FORMAT_MACROS], [], [printf-style format macros])
AC_ARG_ENABLE([debug],
AS_HELP_STRING([--enable-debug], [Enable debugging]),
- [CONFIG_DEBUG="$(echo $enableval | cut -b1)"],
- [CONFIG_DEBUG="y"])
-AC_SUBST([CONFIG_DEBUG])
+ [with_debug=no],
+ [with_debug=yes])
+AC_SUBST(with_debug)
+AM_CONDITIONAL([BUILD_DEBUG], [test "x$with_debug" != xno])
# Checks for programs.
AC_PROG_CC
@@ -128,4 +129,5 @@ AC_OUTPUT
echo "
nft configuration:
- cli support: ${with_cli}"
+ cli support: ${with_cli}
+ enable debugging: ${with_debug}"