summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2019-03-17 18:19:11 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2019-03-18 15:43:46 +0100
commit029a0b11da17766248801d353d1b1863ac4be555 (patch)
treee2bf4c7bbdf2c52bdfdba015b1c009401cf5a4a1 /configure.ac
parent10e19428a5ef9568d9d1ba88f9158eaa0a161cb3 (diff)
configure.ac: Fix a2x check
* If enable_man_doc is set, but a2x can't be found, configure should fail instead of silently disabling man page creation. * The AS_IF block checking $need_a2x is never active (need_a2x has been removed from configure.ac in 13e44a608 and a277479dc). * AC_CHECK_PROG(VAR, ...) is a noop if VAR is already set, allowing the user to explicitly specify the (path to the) binary in VAR. Adjust the AS_IF check to account for this. Signed-off-by: Luis Ressel <aranea@aixah.de> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 9bbd9d32..ccf8db07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,12 +48,9 @@ fi
AM_PROG_AR
AM_PROG_LIBTOOL
-AC_CHECK_PROG(A2X, [a2x], [a2x])
-AM_CONDITIONAL([BUILD_MAN], [test -n "$A2X"])
-
-AS_IF([test "$need_a2x" = "yes"], [
- AC_CHECK_PROG(A2X, [a2x], [found], [no])
- AS_IF([test "$A2X" != "found"],
+AS_IF([test "x$enable_man_doc" = "xyes"], [
+ AC_CHECK_PROG(A2X, [a2x], [a2x], [no])
+ AS_IF([test "$A2X" = "no"],
[AC_MSG_ERROR([a2x not found, please install asciidoc])])
])