summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorArushi Singhal <arushisinghal19971997@gmail.com>2018-08-08 10:49:26 +0530
committerFlorian Westphal <fw@strlen.de>2018-08-14 13:01:55 +0200
commit7da51693235248b78c502c162145539cb9dd8b6f (patch)
tree5c70ca2b5218b17460b484f5f7ff0aec84465e25 /doc/Makefile.am
parentedc3e4f509b84b2661da75a9d059184cd496430d (diff)
nft: doc: fix make distcheck
fix make distcheck for conversion to asciidoc. Signed-off-by: Arushi Singhal <arushisinghal19971997@gmail.com> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 291bcc87..80a37608 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -17,11 +17,11 @@ ASCIIDOCS = ${ASCIIDOC_MAIN} ${ASCIIDOC_INCLUDES}
pdfdir=${docdir}/pdf
-nft.8: ${ASCIIDOCS}
- ${AM_V_GEN}${A2X} --doctype manpage --format manpage ${ASCIIDOC_MAIN}
+.txt.8: ${ASCIIDOCS}
+ ${AM_V_GEN}${A2X} --doctype manpage --format manpage -D ${builddir} $<
-nft.pdf: ${ASCIIDOCS}
- ${AM_V_GEN}${A2X} --doctype manpage --format pdf ${ASCIIDOC_MAIN}
+.txt.pdf: ${ASCIIDOCS}
+ ${AM_V_GEN}${A2X} --doctype manpage --format pdf -D ${builddir} $<
.adoc.pdf:
a2x --doctype manpage --format pdf -D ${builddir} $<