summaryrefslogtreecommitdiffstats
path: root/py/setup.py
diff options
context:
space:
mode:
authorEric Leblond <eric@regit.org>2018-06-19 23:46:53 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2018-06-20 13:51:41 +0200
commitbf9653667a39e32973466a202fdf9edcf881075a (patch)
treec8723359c0128230b8ced5fcdb7bbb8a2aa6f645 /py/setup.py
parentcafd5168ba1e234e8ed446bb0eeaf7eb253a66c2 (diff)
python: installation of binding via make install
setup.py is used to build and install the python binding. Call to setup.py are done in Makefile to proceed to build and installation. Signed-off-by: Eric Leblond <eric@regit.org> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'py/setup.py')
-rwxr-xr-xpy/setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/py/setup.py b/py/setup.py
new file mode 100755
index 00000000..ef143c42
--- /dev/null
+++ b/py/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+from distutils.core import setup
+from nftables import NFTABLES_VERSION
+
+setup(name='nftables',
+ version=NFTABLES_VERSION,
+ description='Libnftables binding',
+ author='Netfilter project',
+ author_email='coreteam@netfilter.org',
+ url='https://netfilter.org/projects/nftables/index.html',
+ packages=['nftables'],
+ provides=['nftables'],
+ package_dir={'nftables':'.'},
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License v2 (GPLv2)',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Topic :: System :: Networking :: Firewalls',
+ ],
+ )