summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPhil Sutter <phil@nwl.cc>2018-03-21 14:16:40 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2018-03-21 14:23:51 +0100
commit2cb7425fef5645631bb81cb06df0c3e73b461f01 (patch)
tree400b069d5a6c4a218842f9a35575846e92cca28f /src/Makefile.am
parentaaf404533ace3c8a355b28deb12793fb11ef3c2a (diff)
Export libnftables (again)
This reverts commits d572d59788143945c2a638f12a5227d9b21ce489 and 9f5e49e147219cd161de8cd80cadf8a444969ef0. Current libnftables API should be stable enough to release it into the public, and after 4aba100e593f ("rule: reset cache iff there is an existing cache") we have a simple way to batch commands through this API. Suggested-by: Pablo Neira Ayuso <pablo@netfilter.org> Signed-off-by: Phil Sutter <phil@nwl.cc> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 677ca396..92e6795f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,7 +24,7 @@ AM_YFLAGS = -d
BUILT_SOURCES = parser_bison.h
-noinst_LTLIBRARIES = libnftables.la
+lib_LTLIBRARIES = libnftables.la
libnftables_la_SOURCES = \
rule.c \
@@ -58,7 +58,7 @@ libnftables_la_SOURCES = \
libnftables.c
# yacc and lex generate dirty code
-noinst_LTLIBRARIES += libparser.la
+noinst_LTLIBRARIES = libparser.la
libparser_la_SOURCES = parser_bison.y scanner.l
libparser_la_CFLAGS = ${AM_CFLAGS} \
-Wno-missing-prototypes \