summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2015-04-09 14:15:15 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2015-04-11 19:22:45 +0200
commit3ed296118a065caff5600e60d4f7ef18e137f9a0 (patch)
tree50e6776142bf52a6a3b1ae5ae65631c1d1faa9ca /src/Makefile.am
parent628122466c32e7f1795c9754a46e6b6b91e71aa5 (diff)
src: restore interface to index cache
nftables used to have a cache to speed up interface name <-> index lookup, restore it using libmnl. This reduces netlink traffic since if_nametoindex() and if_indextoname() open, send a request, receive the list of interface and close a netlink socket for each call. I think this is also good for consistency since nft -f will operate with the same index number when reloading the ruleset. The cache is populated by when nft_if_nametoindex() and nft_if_indextoname() are used for first time. Then, it it released in the output path. In the interactive mode, it is invalidated after each command. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2410fd37..fd632193 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,6 +44,7 @@ nft_SOURCES = main.c \
utils.c \
erec.c \
mnl.c \
+ iface.c \
scanner.l \
parser_bison.y