summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2020-02-17 22:38:13 +0100
committerPablo Neira Ayuso <pablo@netfilter.org>2020-02-19 15:17:11 +0100
commitf8aec603aa7e9dad1316079d42c7efcc52b773fa (patch)
tree2c2f9c1c601610464431683c6d90ca0e8af27d2b /src/Makefile.am
parent9491f1a8eecf1c023ebe3a30b1e92e44a4a39a05 (diff)
src: initial extended netlink error reporting
This patch correlates the in-kernel extended netlink error offset and the location information. Assuming 'foo' table does not exist, then error reporting shows: # nft delete table foo Error: Could not process rule: No such file or directory delete table foo ^^^ Similarly, if table uniquely identified by handle '1234' does not exist, then error reporting shows: # nft delete table handle 1234 Error: Could not process rule: No such file or directory delete table handle 1234 ^^^^ Assuming 'bar' chain does not exists in the kernel, while 'foo' does: # nft delete chain foo bar Error: Could not process rule: No such file or directory delete chain foo bar ^^^ This also gives us a hint when adding rules: # nft add rule ip foo bar counter Error: Could not process rule: No such file or directory add rule ip foo bar counter ^^^ This is based on ("src: basic support for extended netlink errors") from Florian Westphal, posted in 2018, with no netlink offset correlation support. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 740c21f2..9142ab44 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -32,6 +32,7 @@ libnftables_la_SOURCES = \
rule.c \
statement.c \
cache.c \
+ cmd.c \
datatype.c \
expression.c \
evaluate.c \