summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fdf5098a..3c5ba4db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,12 +67,22 @@ AM_COND_IF([BUILD_MAN], [
)]
)
AC_SUBST(DB2MAN)
+
+ [need_a2x=yes]
])
AM_COND_IF([BUILD_PDF], [
AC_CHECK_PROG(DBLATEX, [dblatex], [found], [no])
AS_IF([test "$DBLATEX" == "no"],
[AC_MSG_ERROR([dblatex not found])])
+
+ [need_a2x=yes]
+])
+
+AS_IF([test "$need_a2x" = "yes"], [
+ AC_CHECK_PROG(A2X, [a2x], [found], [no])
+ AS_IF([test "$A2X" != "found"],
+ [AC_MSG_ERROR([a2x not found])])
])
PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.3])