summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2021-11-14 15:52:24 +0000
committerPablo Neira Ayuso <pablo@netfilter.org>2021-11-15 11:42:41 +0100
commit7994d971798b957fd3dd686f48c71c8725bf703e (patch)
tree5f9598aec58508f2b191aaa02d4d118d2c2da8bd /Makefile.am
parent6cc4b5a9968708178989c850177ffd734c2b9eae (diff)
build: skip sub-directories containing disabled plugins
Currently, make enters all sub-directories containing source-code, even if they only contain optional targets which are not configured to be built. Instead, change the Makefiles so that the sub-directories are optional, rather than the targets. Group sub-directory definitions consistently at the top of the Makefiles that contain them. Trim a few leading and trailing blank lines. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 7ea5db5..bf390a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,11 @@
+SUBDIRS = include libipulog src input filter output
-ACLOCAL_AMFLAGS = -I m4
+ACLOCAL_AMFLAGS = -I m4
dist_man_MANS = ulogd.8
EXTRA_DIST = ulogd.conf.in doc
-SUBDIRS = include libipulog src input filter output
-
noinst_DATA = ulogd.conf
edit = sed \
@@ -17,4 +16,3 @@ ulogd.conf: Makefile $(srcdir)/ulogd.conf.in
dist-hook:
rm -f ulogd.conf
-