summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-11-05 19:25:16 +0100
committerJan Engelhardt <jengelh@medozas.de>2010-11-05 19:32:04 +0100
commit99d59b94d6ec46dddb05e518f253a983f0450e3f (patch)
tree4a166a87063a374f049e42474beca26243e0d378 /configure.ac
parenta12a31bfbbd314a2fcb3437f9211a53bd2a97c00 (diff)
build: propagate global CFLAGS
We must not override CFLAGS, because that will break when the user overrides CFLAGS again at make time (which he is entitled to). So, name our CFLAGS regular_CFLAGS, and also include that across all Makefiles so that they are actually uesd for all the code. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2447574..fec034e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,7 +32,8 @@ dnl Checks for library functions.
AC_FUNC_VPRINTF
AC_CHECK_FUNCS(socket strerror)
-CFLAGS="$CFLAGS -Wall -Wextra -Wno-unused-parameter"
+regular_CFLAGS="-Wall -Wextra -Wno-unused-parameter"
+AC_SUBST([regular_CFLAGS])
dnl Check for the right nfnetlink version
LIBNFNETLINK_REQUIRED=0.0.39