summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Sowden <jeremy@azazel.net>2022-01-09 11:57:50 +0000
committerPablo Neira Ayuso <pablo@netfilter.org>2022-01-11 22:15:33 +0100
commit0efac6993adb339678890720bceb9432e85cd668 (patch)
treeafe78b1e329512958694b9ccbfe24fefa8e2f8ed /configure.ac
parentc7280c85d29c960b90488eab0005b0c1f0e4d9e7 (diff)
build: if `--enable-mysql` is `yes`, abort if libmysqlclient is not found
If MySQL support has been explicitly requested, abort if it is not available. Signed-off-by: Jeremy Sowden <jeremy@azazel.net> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bd1059a..620cb34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,6 +156,12 @@ AS_IF([test "x$enable_mysql" != "xno"], [
AC_MSG_RESULT([no])
])
+ AS_IF([test "x$libmysqlclient_LIBS" = "x"], [
+ AS_IF([test "x$enable_mysql" = "xyes"], [
+ AC_MSG_ERROR([libmysqlclient not found])
+ ])
+ ])
+
])
])