summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Julien <victor@inliniac.net>2013-04-05 18:28:14 +0200
committerEric Leblond <eric@regit.org>2013-05-21 19:57:07 +0200
commit61b7946e90165de3ebf943e5c454fc0b62c029ad (patch)
treecc08d6199abbbbc20d2b6480a4d459d5a61ae1f9 /configure.ac
parent6049e0e77a0464cff09b4c7a9a531b6f8c25f5fc (diff)
Exec libmnl config check only if nfacct is enabled
In case nfacct is not enabled in ulogd2, libmnl is not used. So it shouldn't be a hard global dependency, but instead only a dependency in case nfacct is enabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7351749..f2eaf26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,6 @@ AC_CHECK_LIB(pthread, pthread_create)
dnl Check for the right nfnetlink version
PKG_CHECK_MODULES([LIBNFNETLINK], [libnfnetlink >= 1.0.1])
-PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.3])
AC_ARG_ENABLE(nflog,
AS_HELP_STRING([--enable-nflog], [Enable nflog module [default=yes]]),,[enable_nflog=yes])
AS_IF([test "x$enable_nflog" = "xyes"], [
@@ -61,6 +60,7 @@ AM_CONDITIONAL([BUILD_NFCT], [test "x$enable_nfct" = "xyes"])
AC_ARG_ENABLE(nfacct,
AS_HELP_STRING([--enable-nfacct], [Enable nfacct module [default=yes]]),,[enable_nfacct=yes])
AS_IF([test "x$enable_nfacct" = "xyes"], [
+ PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.3])
PKG_CHECK_MODULES([LIBNETFILTER_ACCT], [libnetfilter_acct >= 1.0.1])
AC_DEFINE([BUILD_NFACCT], [1], [Building nfacct module])
])