summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
author/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org>2005-11-29 08:43:51 +0000
committer/C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org </C=DE/ST=Berlin/L=Berlin/O=Netfilter Project/OU=Development/CN=laforge/emailAddress=laforge@netfilter.org>2005-11-29 08:43:51 +0000
commit05dd8b5b23da04add3bac2e82dce20a310198351 (patch)
tree65d48742078c855f83bb0c84fd9e6e26aa3d5f84 /configure.in
parentca68a2540a5118d44a9e169e0bc6802d7ad04de8 (diff)
fixes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index f586426..fc758e2 100644
--- a/configure.in
+++ b/configure.in
@@ -31,6 +31,9 @@ AC_CHECK_FUNCS(socket strerror)
AC_CHECK_HEADER([libnetfilter_log/linux_nfnetlink_log.h], [AC_MSG_RESULT([found])],
[AC_MSG_ERROR([libnetfilter_log Version 0.0.11 or later needed])])
+AC_CHECK_HEADER([libnetfilter_conntrack/libnetfilter_conntrack.h], [AC_MSG_RESULT([found])],
+ [AC_MSG_ERROR([libnetfilter_conntrack Version 0.0.11 or later needed])])
+
DATABASE_DIR=""
DATABASE_LIB=""
DATABASE_LIB_DIR=""
@@ -71,7 +74,7 @@ if test x$mysqldir = x
then
AC_MSG_WARN(MySQL backend not used)
else
- AC_DEFINE(HAVE_MYSQL)
+ AC_DEFINE([HAVE_MYSQL], [], [Description])
MYSQLINCLUDES=${mysqldir}/include${mysqldir_suffix}
MYSQLLIBS=${mysqldir}/lib${mysqldir_suffix}
@@ -165,7 +168,7 @@ if test x$pgsqldir = x
then
AC_MSG_WARN(PGSQL backend not used)
else
- AC_DEFINE(HAVE_PGSQL)
+ AC_DEFINE([HAVE_PGSQL], [], [Description])
for i in include include/postgresql include/pgsql
do
if test -f ${pgsqldir}/$i/libpq-fe.h
@@ -216,4 +219,4 @@ AC_SUBST(HAVE_PCAP_H)
AM_CONDITIONAL(HAVE_MYSQL, test x$mysqldir != x)
AM_CONDITIONAL(HAVE_PGSQL, test x$pgsqldir != x)
-AC_OUTPUT(doc/Makefile conffile/Makefile libipulog/Makefile input/Makefile input/packet/Makefile input/flow/Makefile filter/Makefile filter/raw2packet/Makefile filter/packet2flow/Makefile output/Makefile output/pcap/Makefile output/mysql/Makefile output/pgsql/Makefile src/Makefile Makefile Rules.make)
+AC_OUTPUT(doc/Makefile libipulog/Makefile input/Makefile input/packet/Makefile input/flow/Makefile filter/Makefile filter/raw2packet/Makefile filter/packet2flow/Makefile output/Makefile output/pcap/Makefile output/mysql/Makefile output/pgsql/Makefile src/Makefile Makefile Rules.make)