summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPierre Chifflier <chifflier@inl.fr>2008-12-01 13:41:56 +0100
committerEric Leblond <eric@inl.fr>2008-12-09 00:19:36 +0100
commitb311ead995d2de9fc3435b845d473324049c0fdd (patch)
tree87f2aa7d36d84678b337915822efef3e3ddde753 /configure.in
parente706f92c94a5dd11a4e5286bac3305e0a10b19ee (diff)
Search for libdbi includes during configure
libdbi is a database-independent abstraction layer in C, similar to the DBI/DBD layer in Perl. Signed-off-by: Pierre Chifflier <chifflier@inl.fr> Signed-off-by: Eric Leblond <eric@inl.fr>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0e173a3..f9a55a2 100644
--- a/configure.in
+++ b/configure.in
@@ -53,6 +53,9 @@ AM_CONDITIONAL(HAVE_MYSQL, test "x$MYSQL_LIB" != "x")
CT_CHECK_SQLITE3_DB()
AM_CONDITIONAL(HAVE_SQLITE3, test "x$SQLITE3_LIB" != "x")
+CT_CHECK_DBI()
+AM_CONDITIONAL(HAVE_DBI, test "x$DBI_LIB" != "x")
+
CT_CHECK_PCAP()
AM_CONDITIONAL(HAVE_PCAP, test "x$PCAP_LIB" != "x")