summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5dfb661..942c47c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,11 +1,14 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(ulogd.c)
+AC_INIT
+
+AM_INIT_AUTOMAKE(ulogd, 2.0.0alpha)
+AM_CONFIG_HEADER(config.h)
dnl Checks for programs.
AC_PROG_MAKE_SET
AC_PROG_CC
-AC_CHECK_TOOL(LD, ld)
AC_PROG_INSTALL
+AM_PROG_LIBTOOL
dnl Checks for libraries.
AC_CHECK_LIB(dl, dlopen)
@@ -210,4 +213,4 @@ AC_SUBST(HAVE_PCAP_H)
AM_CONDITIONAL(HAVE_MYSQL, test x$mysqldir != x)
AM_CONDITIONAL(HAVE_PGSQL, test x$pgsqldir != x)
-AC_OUTPUT(doc/Makefile conffile/Makefile libipulog/Makefile input/packet/Makefile input/flow/Makefile filter/raw2packet/Makefile filter/packet2flow/Makefile output/Makefile output/mysql/Makefile output/pgsql/Makefile Makefile Rules.make)
+AC_OUTPUT(doc/Makefile conffile/Makefile libipulog/Makefile input/Makefile input/packet/Makefile input/flow/Makefile filter/Makefile filter/raw2packet/Makefile filter/packet2flow/Makefile output/Makefile output/mysql/Makefile output/pgsql/Makefile src/Makefile Makefile Rules.make)