summaryrefslogtreecommitdiffstats
path: root/input/packet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'input/packet/Makefile.am')
-rw-r--r--input/packet/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/input/packet/Makefile.am b/input/packet/Makefile.am
index 1c884b8..1c3151d 100644
--- a/input/packet/Makefile.am
+++ b/input/packet/Makefile.am
@@ -2,7 +2,12 @@
AM_CPPFLAGS = -I$(top_srcdir)/include ${LIBNETFILTER_LOG_CFLAGS}
AM_CFLAGS = ${regular_CFLAGS}
-pkglib_LTLIBRARIES = ulogd_inppkt_ULOG.la ulogd_inppkt_UNIXSOCK.la
+pkglib_LTLIBRARIES = ulogd_inppkt_UNIXSOCK.la
+
+if BUILD_ULOG
+pkglib_LTLIBRARIES += ulogd_inppkt_ULOG.la
+endif
+
if BUILD_NFLOG
pkglib_LTLIBRARIES += ulogd_inppkt_NFLOG.la
endif