summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f326f96..c541034 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,9 @@ AC_ARG_ENABLE([cthelper],
AC_ARG_ENABLE([cttimeout],
AS_HELP_STRING([--disable-cttimeout], [Do not build timeout support]),
[enable_cttimeout="$enableval"], [enable_cttimeout="yes"])
+AC_ARG_ENABLE([systemd],
+ AS_HELP_STRING([--enable-systemd], [Build systemd support]),
+ [enable_systemd="$enableval"], [enable_systemd="no"])
PKG_CHECK_MODULES([LIBNFNETLINK], [libnfnetlink >= 1.0.1])
PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.3])
@@ -77,6 +80,12 @@ AS_IF([test "x$enable_cthelper" = "xyes"], [
])
AM_CONDITIONAL([HAVE_CTHELPER], [test "x$enable_cthelper" = "xyes"])
+AS_IF([test "x$enable_systemd" = "xyes"], [
+ PKG_CHECK_MODULES([LIBSYSTEMD], [libsystemd >= 227])
+ AC_DEFINE([BUILD_SYSTEMD], [1], [Building systemd support])
+])
+AM_CONDITIONAL([HAVE_SYSTEMD], [test "x$enable_systemd" = "xyes"])
+
AC_CHECK_HEADERS([linux/capability.h],, [AC_MSG_ERROR([Cannot find linux/capabibility.h])])
# Checks for libraries.
@@ -146,4 +155,5 @@ AC_OUTPUT
echo "
conntrack-tools configuration:
userspace conntrack helper support: ${enable_cthelper}
- conntrack timeout support: ${enable_cttimeout}"
+ conntrack timeout support: ${enable_cttimeout}
+ systemd support: ${enable_systemd}"