summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 92a0389..46dd7b8 100644
--- a/configure.in
+++ b/configure.in
@@ -20,6 +20,14 @@ dnl Dependencies
LIBNFNETLINK_REQUIRED=0.0.32
LIBNETFILTER_CONNTRACK_REQUIRED=0.0.91
+AC_CHECK_PROG(HAVE_PKG_CONFIG, pkg-config, yes)
+if test "x$HAVE_PKG_CONFIG" = "x"
+then
+ echo "*** Error: No suitable pkg-config found. ***"
+ echo " Please install the 'pkg-config' package."
+ exit 1
+fi
+
PKG_CHECK_MODULES(LIBNFNETLINK, libnfnetlink >= $LIBNFNETLINK_REQUIRED,,
AC_MSG_ERROR(Cannot find libnfnetlink >= $LIBNFNETLINK_REQUIRED))