summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Kolchmeyer <rkolchmeyer@google.com>2022-03-18 15:58:54 -0700
committerFlorian Westphal <fw@strlen.de>2022-03-22 11:21:37 +0100
commit3f3a794a96ca7057d6e981567ef84f4f4bdb43e5 (patch)
treef280468022db42340100a7361339d9b0dcff1e93 /Makefile.am
parent3af72f100ad783b0204ce519de26a639f920b558 (diff)
ebtables: fix the 'static' build target
Currently, `make static` results in the following error: undefined reference to `main' I took a guess at what 'static' is supposed to produce, and thought it would make sense to use the main definition from ebtables-standalone.c. Also, producing 'static' by linking against a libebtc.a results in a non-functional program (immediate segmentation fault). This is because the initialization functions defined in libebtc.a aren't linked into the result program. I ran into issues trying to use the --whole-archive linker option with libtool, so I figured linking in the libebtc object files directly was the simplest approach. Signed-off-by: Robert Kolchmeyer <rkolchmeyer@google.com> Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6181003..b246064 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,9 +50,8 @@ ebtables_legacy_LDADD = libebtc.la
ebtablesd_LDADD = libebtc.la
ebtables_legacy_restore_SOURCES = ebtables-restore.c
ebtables_legacy_restore_LDADD = libebtc.la
-static_SOURCES = ebtables.c
+static_SOURCES = ebtables-standalone.c $(libebtc_la_SOURCES)
static_LDFLAGS = -static
-static_LDADD = libebtc.la
examples_ulog_test_ulog_SOURCES = examples/ulog/test_ulog.c getethertype.c
daemon: ebtablesd ebtablesu