summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-04-22 17:14:21 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-04-22 17:14:21 +0200
commit62f71e22a1db90eee62ea9688f0c77cb6cf5ccae (patch)
tree73442db9c9c96f9bee4e318b8a3afc58fea01ef7 /Makefile.am
parent9638135a8ea91a157a68148fb1d84edec52c313b (diff)
Tenth stage to ipset-5
Add new test files and toplevel files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..f94689b
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,49 @@
+## Process this file with automake to produce Makefile.in
+
+include $(top_srcdir)/Make_global.am
+
+if ! WITH_KBUILDDIR
+KBUILD_OUTPUT=/lib/modules/`uname -r`/build
+else
+KBUILD_OUTPUT=$(KBUILDDIR)
+endif
+if ! WITH_MAXSETS
+IP_SET_MAX=256
+else
+IP_SET_MAX=$(MAXSETS)
+endif
+if ENABLE_VERBOSE
+V=1
+else
+V=0
+endif
+
+SUBDIRS = lib src
+
+modules:
+ cd kernel; make -C $(KBUILD_OUTPUT) M=`pwd` V=$V IP_SET_MAX=$(IP_SET_MAX) modules
+
+modules_install:
+ cd kernel; make -C $(KBUILD_OUTPUT) M=`pwd` modules_install
+
+modules_clean:
+ cd kernel; make -C $(KBUILD_OUTPUT) M=`pwd` clean
+
+update_includes:
+ ./update ip_set.h
+ ./update ip_set_bitmap.h
+ ./update ip_set_hash.h
+
+tests:
+ cd tests; ./runtest.sh
+
+cleanup_dirs := . include/libipset lib src tests
+
+tidy: distclean
+ rm -rf .deps $(foreach dir,$(cleanup_dirs),$(wildcard $(dir)/*~))
+ rm -rf aclocal.m4 autom4te.cache
+ rm -rf config.* configure depcomp install-sh libtool ltmain.sh
+ rm -rf Makefile Makefile.in */Makefile */Makefile.in
+ rm -rf missing stamp-h1
+
+.PHONY: modules modules_instal modules_clean update_includes tests