summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2017-03-23 16:13:16 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2017-03-23 22:06:36 +0100
commit1d90b77974a41becda46a16a78f90ecd43e2c222 (patch)
tree47cea4f7fe5198d628e1a5cb66a3cadd7589a5f1 /configure.ac
parentf5bb0ae5317175e47b50216d53da5342390a13b6 (diff)
Compatibility: handle changes in 4.10 kernel tree
Handle changes in struct xt_action_param and the new xt_family(), xt_net() interfaces (reported by Jan Engelhardt).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cdb24d2..c7a030c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -508,6 +508,37 @@ else
AC_SUBST(HAVE_NET_IN_XT_ACTION_PARAM, undef)
fi
+AC_MSG_CHECKING([kernel source for struct nf_hook_state in struct xt_action_param])
+if test -f $ksourcedir/include/linux/netfilter/x_tables.h && \
+ $AWK '/^struct xt_action_param / {for(i=1; i<=10; i++) {getline; print}}' $ksourcedir/include/linux/netfilter/x_tables.h | \
+ $GREP -q 'struct nf_hook_state '; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_STATE_IN_XT_ACTION_PARAM, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_STATE_IN_XT_ACTION_PARAM, undef)
+fi
+
+AC_MSG_CHECKING([kernel source for xt_family() in x_tables.h])
+if test -f $ksourcedir/include/linux/netfilter/x_tables.h && \
+ $GREP -q 'xt_family' $ksourcedir/include/linux/netfilter/x_tables.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_XT_FAMILY, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_XT_FAMILY, undef)
+fi
+
+AC_MSG_CHECKING([kernel source for xt_net() in x_tables.h])
+if test -f $ksourcedir/include/linux/netfilter/x_tables.h && \
+ $GREP -q 'xt_net' $ksourcedir/include/linux/netfilter/x_tables.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_XT_NET, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_XT_NET, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then