summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2017-09-11 20:45:44 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2017-09-11 20:45:44 +0200
commit2c9ec23d25766a71ed3f262007b8f2211cd4a769 (patch)
tree1d82e1f425052ff4848239e9482171b60dd1ac46 /configure.ac
parentad62744cab5be7751fb56d2476b8427fc9938fe2 (diff)
Backport patch: netlink: pass extended ACK struct to parsing functions
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c6354f..c818557 100644
--- a/configure.ac
+++ b/configure.ac
@@ -559,6 +559,16 @@ else
AC_SUBST(HAVE_NETLINK_EXTENDED_ACK, undef)
fi
+AC_MSG_CHECKING([kernel source for passing extended ACK struct to parsing functions])
+if test -f $ksourcedir/include/linux/netlink.h && \
+ $AWK '/^static inline int nla_parse_nested/ {for(i=1; i<=4; i++) {getline; print}}' $ksourcedir/include/linux/netlink.h | $GREP -q 'struct netlink_ext_ack'; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_PASSING_EXTENDED_ACK_TO_PARSERS, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_PASSING_EXTENDED_ACK_TO_PARSERS, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then