summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@netfilter.org>2019-11-01 15:40:33 +0100
committerJozsef Kadlecsik <kadlec@netfilter.org>2019-11-01 15:40:33 +0100
commitd2bf22865663c260c9eb4ca2cba63dbac9e258f9 (patch)
treec09ec8fb321120ea12fb77a8cbf3d9d590d50339 /configure.ac
parent2b2c1d85bbc4e24e1350c3075d5e653104c91a41 (diff)
Fix compatibility support for netlink extended ACK and add synchronize_rcu_bh() checking
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 75f43c7..5a0f18a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -581,7 +581,7 @@ fi
AC_MSG_CHECKING([kernel source for netlink extended ACK])
if test -f $ksourcedir/include/linux/netlink.h && \
- $AWK '/^extern void netlink_ack\(/,/\)/' $ksourcedir/include/linux/netlink.h | $GREP -q 'const struct netlink_ext_ack'; then
+ $AWK '/void netlink_ack\(/,/\)/' $ksourcedir/include/linux/netlink.h | $GREP -q 'const struct netlink_ext_ack'; then
AC_MSG_RESULT(yes)
AC_SUBST(HAVE_NETLINK_EXTENDED_ACK, define)
else
@@ -649,6 +649,17 @@ else
AC_SUBST(HAVE_STRSCPY, undef)
fi
+AC_MSG_CHECKING([kernel source for synchronize_rcu_bh() in rcutiny.h and rcupdate.h])
+if test -f $ksourcedir/include/linux/rcupdate.h && \
+ $GREP -q 'static inline void synchronize_rcu_bh' \
+ $ksourcedir/include/linux/rcutiny.h $ksourcedir/include/linux/rcupdate.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_SYNCHRONIZE_RCU_BH, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_SYNCHRONIZE_RCU_BH, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then