summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSerhey Popovych <serhe.popovych@gmail.com>2019-11-29 11:21:32 +0200
committerJozsef Kadlecsik <kadlec@netfilter.org>2019-12-09 11:07:02 +0100
commita065f8ed355f08131c39787b4c7a41543ff643b3 (patch)
tree5bc04778f2d526dd57b783dc5bc570fa34659a76 /configure.ac
parent4eda9fd68157c444f70541bd10fde3c36e09f0f1 (diff)
em_ipset: Build on old kernels
Make sure TCF_EM_IPSET defined and corresponds to current upstream value if not defined in target kernel. You need iproute2 version that supports em_ipset to communicate correctly. Include ip_set_compat.h after pkt_cls.h to prevent TCF_EM_IPSET redefine error. Detect skb->iif => skb->skb_iif rename after commit 8964be4a9a5c ("net: rename skb->iif to skb->skb_iif"). Add dev_get_by_index_rcu() define pointing to __dev_get_by_index() to build on RHEL6 kernels with explicit note that this may not work on all architectures. Always build em_ipset regardless of CONFIG_NET_EMATCH_IPSET option. Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com> Signed-off-by: Jozsef Kadlecsik <kadlec@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 17ba184..e3ddcce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -554,6 +554,17 @@ else
fi
fi
+AC_MSG_CHECKING([kernel source for iif to skb_iif rename in struct sk_buff])
+if test -f $ksourcedir/include/linux/skbuff.h && \
+ $AWK '/^struct sk_buff {/,/^};$/' $ksourcedir/include/linux/skbuff.h | \
+ $GREP -q 'skb_iif'; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_SKB_IIF, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_SKB_IIF, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net in struct xt_action_param])
if test -f $ksourcedir/include/linux/netfilter/x_tables.h && \
$AWK '/^struct xt_action_param /,/^}/' $ksourcedir/include/linux/netfilter/x_tables.h | \