summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-07-13 14:18:22 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2010-07-13 14:18:22 +0200
commit1b8c69e14d97bf5d0e973740c5802fdbf96f756d (patch)
tree3103a20e41a680bb851785c52ff7050902008a1b /configure.ac
parent8dd10256cb24ceade8b40bd1604f03ddac8589e2 (diff)
Compatibility and documentation fixesv5.0-pre6
Makefile fixes: compiler flags README and manpage fixes Compatibility with newer gcc releases (4.4.x) Compatibility with the 2.6.35 kernel tree
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f75ef49..7622ac4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,18 @@ then
AC_MSG_ERROR([Invalid kernel build directory $kbuilddir])
fi
+if test ! -e "$kbuilddir/.config"
+then
+ AC_MSG_ERROR([The kernel build directory $kbuilddir is not configured])
+fi
+
+AC_PROG_GREP
+
+if test "X`$GREP '^CONFIG_IP6_NF_IPTABLES=' $kbuilddir/.config`" = "X"
+then
+ AC_MSG_ERROR([The kernel build directory $kbuilddir is not configured with IP6_NF_IPTABLES support (ip6tables)])
+fi
+
dnl Check kernel dependencies: nfnetlink.h
NFNL_CB_CONST="`./check_const $kbuilddir/include/linux/netfilter/nfnetlink.h`"
AC_SUBST(NFNL_CB_CONST)