summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2017-09-11 21:12:13 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2017-09-11 21:12:13 +0200
commit54185b4302638bda745b7459ed618bb072b41c71 (patch)
tree954f375827861e076a825c8d40c7ae9a02d871e7 /configure.ac
parentd88c5b79db7f84c6bce15b0d7cf461d725cb8824 (diff)
Backport patch: sctp: remove the typedef sctp_sctphdr_t
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 26883d7..d88d5b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -579,6 +579,16 @@ else
AC_SUBST(HAVE_PASSING_EXTENDED_ACK_TO_CALLBACKS, undef)
fi
+AC_MSG_CHECKING([kernel source for no typedef sctp_sctphdr_t])
+if test -f $ksourcedir/include/linux/sctp.h && \
+ $GREP -q '^typedef struct sctphdr' $ksourcedir/include/linux/sctp.h; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_TYPEDEF_SCTP_SCTPHDR_T, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_TYPEDEF_SCTP_SCTPHDR_T, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then