summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSerhey Popovych <serhe.popovych@gmail.com>2019-11-29 11:21:30 +0200
committerJozsef Kadlecsik <kadlec@netfilter.org>2019-12-09 11:03:04 +0100
commit66d5125848150fbf8d41f456e2921a38b7690532 (patch)
tree1009bd2f49bfe262fbcb27f39baea28327d944e2 /configure.ac
parentde06e92fc9b22f9c78316a2f2f4bc524696a91f6 (diff)
configure.ac: Support building with old autoconf 2.63
This version found on RHEL6 making autoreconf fail with following error: configure.ac:61: error: possibly undefined macro: AS_VAR_COPY If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. Apply fix from https://github.com/gdnsd/gdnsd/issues/85 to fix problem. Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com> Signed-off-by: Jozsef Kadlecsik <kadlec@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8fe1890..17ba184 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,12 @@ AS_VAR_IF([$1], [""], [$5], [$4])dnl
])# PKG_CHECK_VAR
])
+# This hack makes PKG_CHECK_VARS from m4/pkg.m4 work on autoconf 2.63
+# (courtesy of sunnybear in https://github.com/gdnsd/gdnsd/issues/85)
+m4_ifndef([AS_VAR_COPY],
+[m4_define([AS_VAR_COPY],
+[AS_LITERAL_IF([$1[]$2], [$1=$$2], [eval $1=\$$2])])])
+
if test "x$enable_bashcompl" = "xyes"; then
PKG_CHECK_VAR(bashcompdir, [bash-completion], [completionsdir], , bashcompdir="${sysconfdir}/bash_completion.d")
AC_SUBST(bashcompdir)