summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2016-02-16 07:50:22 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2016-02-16 07:50:22 +0100
commitb418935ba84bce0fd2dd332b87df8d56c707e056 (patch)
treef2f1d3e74e50ae72e18652f7c6d7c409c32e1b24 /configure.ac
parent9592763b89d03e988fb46f2fc05c0cdc992534d3 (diff)
netfilter: nfnetlink: pass down netns pointer to call() and call_rcu()
Backport patch from Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6627ee7..43d3923 100644
--- a/configure.ac
+++ b/configure.ac
@@ -426,6 +426,17 @@ else
AC_SUBST(HAVE_NLA_PUT_IN_ADDR, undef)
fi
+AC_MSG_CHECKING([kernel source for struct net in struct nfnl_callback])
+if test -f $ksourcedir/include/linux/netfilter/nfnetlink.h && \
+ $AWK '/^struct nfnl_callback / {for(i=1; i<=3; i++) {getline; print}}' $ksourcedir/include/linux/netfilter/nfnetlink.h | \
+ $GREP -q 'struct net'; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_NET_IN_NFNL_CALLBACK_FN, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_NET_IN_NFNL_CALLBACK_FN, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then