summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSerhey Popovych <serhe.popovych@gmail.com>2019-11-29 11:21:28 +0200
committerJozsef Kadlecsik <kadlec@netfilter.org>2019-12-09 11:01:14 +0100
commitbb750b8ded015c4447cc2eee601709f50d06574e (patch)
tree3281b6270ee3f3e29b293020b4b41e070437a133 /configure.ac
parenta1ccbae83744041bddf4038323a3428e8a20ef72 (diff)
configure.ac: Add cond_resched_rcu() checks
It was introduced with commit f6f3c437d09e ("sched: add cond_resched_rcu() helper") since v3.11 upstream kernel. To support building on older kernels add implementation to ip_set_compat.h. Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com> Signed-off-by: Jozsef Kadlecsik <kadlec@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e0025df..ced2880 100644
--- a/configure.ac
+++ b/configure.ac
@@ -333,6 +333,16 @@ else
AC_SUBST(HAVE_IPV6_SKIP_EXTHDR_ARGS, 3)
fi
+AC_MSG_CHECKING([kernel source for cond_resched_rcu])
+if test -f $ksourcedir/include/linux/sched.h && \
+ $AWK '/( |\t)cond_resched_rcu\(/,/\)/' $ksourcedir/include/linux/sched.h | $GREP -q 'cond_resched_rcu'; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_COND_RESCHED_RCU, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_COND_RESCHED_RCU, undef)
+fi
+
AC_MSG_CHECKING([kernel source for bool checkentry function prototype])
if test -f $ksourcedir/include/linux/netfilter/x_tables.h && \
$GREP -q 'bool .\*checkentry.' $ksourcedir/include/linux/netfilter/x_tables.h; then