summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric W. Biederman <ebiederm@xmission.com>2016-10-11 22:19:51 +0200
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2016-10-11 22:19:51 +0200
commitc71fc214fe8e134d6e8ffeed4043bcb4320e48d4 (patch)
treeea5febf175811f7af57fbc5bf40474d7d2d5540e /configure.ac
parentf0c110ecc4b8b04e1bbf6766284d3bf52cd73a30 (diff)
netfilter: x_tables: Pass struct net in xt_action_param
As xt_action_param lives on the stack this does not bloat any persistent data structures. This is a first step in making netfilter code that needs to know which network namespace it is executing in simpler. Signed-off-by: "Eric W. Biederman" <ebiederm@xmission.com> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f046e8b..e1b1483 100644
--- a/configure.ac
+++ b/configure.ac
@@ -497,6 +497,17 @@ else
AC_SUBST(HAVE_TC_SKB_PROTOCOL, undef)
fi
+AC_MSG_CHECKING([kernel source for struct net in struct xt_action_param])
+if test -f $ksourcedir/include/linux/netfilter/x_tables.h && \
+ $AWK '/^struct xt_action_param / {for(i=1; i<=8; i++) {getline; print}}' $ksourcedir/include/linux/netfilter/x_tables.h | \
+ $GREP -q 'struct net '; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_NET_IN_XT_ACTION_PARAM, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_NET_IN_XT_ACTION_PARAM, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then