summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2013-10-27 19:00:36 +0100
committerJozsef Kadlecsik <kadlec@blackhole.kfki.hu>2013-10-27 19:00:36 +0100
commitf1446f13d8678020887da93760cdbb59ed90e124 (patch)
tree0a5fb27397fc14ee6c30745a34f3ed00bfc782e8 /configure.ac
parent6e85776d53e2ceb559cc43f70c14b90303aa8a94 (diff)
net->user_ns is available starting from 3.8, add compatibility checking
Reported by Jan Engelhardt
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d56328c..c5f3770 100644
--- a/configure.ac
+++ b/configure.ac
@@ -303,6 +303,16 @@ else
AC_SUBST(HAVE_NET_OPS_ID, undef)
fi
+AC_MSG_CHECKING([kernel source for user_ns in struct net])
+if test -f $ksourcedir/include/net/net_namespace.h && \
+ $AWK '/^struct net \{/ {for(i=1; i<=20; i++) {getline; print}}' $ksourcedir/include/net/net_namespace.h | $GREP -q 'user_ns'; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_USER_NS_IN_STRUCT_NET, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_USER_NS_IN_STRUCT_NET, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then