summaryrefslogtreecommitdiffstats
path: root/include/libipset/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2021-06-25 22:30:42 +0200
committerJozsef Kadlecsik <kadlec@netfilter.org>2021-06-26 23:07:35 +0200
commit325af556cd3a6d1636c0cd355b494c87f58397e0 (patch)
tree1c433f1f08d467074908e8edf132d2a940a66bef /include/libipset/Makefile.am
parentff7f000ef2dbe81444a4e204dbab9a2177c35e21 (diff)
add ipset to nftables translation infrastructure
This patch provides the ipset-translate utility which allows you to translate your existing ipset file to nftables. The ipset-translate utility is actually a symlink to ipset, which checks for 'argv[0] == ipset-translate' to exercise the translation path. You can translate your ipset file through: ipset-translate restore < sets.ipt This patch reuses the existing parser and API to represent the sets and the elements. There is a new ipset_xlate_set dummy object that allows to store a created set to fetch the type without interactions with the kernel. Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org> Signed-off-by: Jozsef Kadlecsik <kadlec@netfilter.org>
Diffstat (limited to 'include/libipset/Makefile.am')
-rw-r--r--include/libipset/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/libipset/Makefile.am b/include/libipset/Makefile.am
index c7f7b2b..2c04029 100644
--- a/include/libipset/Makefile.am
+++ b/include/libipset/Makefile.am
@@ -17,6 +17,7 @@ pkginclude_HEADERS = \
transport.h \
types.h \
ipset.h \
- utils.h
+ utils.h \
+ xlate.h
EXTRA_DIST = debug.h icmp.h icmpv6.h