summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-10-19 16:02:04 +0200
committerJan Engelhardt <jengelh@medozas.de>2010-10-19 17:53:28 +0200
commit7607e809e947dbdc89de84cbad960e5aa0accc91 (patch)
tree2b7e93f85aac8575eeadcc2ebb41b38dfa24ffa7 /lib/Makefile.am
parentd6484ee2f3b256ec2a011bad383175388fd4ee05 (diff)
build: use libmnl's pkgconfig files
libmnl installs .pc files that we can directly use and which are preferable over AC_CHECK_LIB. Also make sure that libipset.so is linked with libmnl, otherwise linking errors can ensue when a program tries to link to libipset. Furthermore, remove the now-unused LIBS variable. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index bf4e133..74f36e8 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,11 +1,11 @@
include $(top_srcdir)/Make_global.am
-AM_CFLAGS += -fPIC
-LIBS =
+AM_CFLAGS += -fPIC ${libmnl_CFLAGS}
lib_LTLIBRARIES = libipset.la
libipset_la_LDFLAGS = -version-info $(LIBVERSION)
+libipset_la_LIBADD = ${libmnl_LIBS}
libipset_la_SOURCES = \
data.c \
mnl.c \