summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-08-28 19:13:47 +0200
committerJan Engelhardt <jengelh@medozas.de>2011-08-31 22:29:38 +0200
commit5fccd38bbf4892718e58f0b006aa6724aec4f7f8 (patch)
tree7e845a9740810ddc42e87d4b4d30c360f708f975 /lib/Makefile.am
parent25eb53a35e262ff359188bf6b8d418909c18f982 (diff)
build: move ipset_errcode into library
The library cannot stand on its own: 19:13 seven:../ipset/lib > ldd -r .libs/libipset.so.1 linux-vdso.so.1 => (0x00007fff9a569000) libmnl.so.0 => /usr/lib64/libmnl.so.0 (0x00007fd42ae5c000) libc.so.6 => /lib64/libc.so.6 (0x00007fd42aaef000) /lib64/ld-linux-x86-64.so.2 (0x00007fd42b28d000) undefined symbol: ipset_errcode (.libs/libipset.so.1) Resolve this by moving ipset_errcode into the library. Reported-by: Arkadiusz Miskiewicz <a.miskiewicz@gmail.com> References: http://marc.info/?l=netfilter-devel&m=131435791514602&w=2
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 7913877..8afe611 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -8,6 +8,7 @@ libipset_la_LDFLAGS = -version-info $(LIBVERSION)
libipset_la_LIBADD = ${libmnl_LIBS}
libipset_la_SOURCES = \
data.c \
+ errcode.c \
icmp.c \
icmpv6.c \
mnl.c \