summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 684ebee..e3404fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,6 +16,7 @@ IP_SET_MAX=$(MAXSETS)
endif
SUBDIRS = include/libipset lib src utils
+INSTALL_MOD_PATH = /
sparse:
$(MAKE) -C lib sparse-check
@@ -71,7 +72,7 @@ modules_install:
if WITH_KMOD
${MAKE} -C $(KBUILD_OUTPUT) M=$$PWD/kernel/net \
KDIR=$$PWD/kernel modules_install
- @modinfo ip_set_hash_ip | ${GREP} /extra/ >/dev/null || echo "$$DEPMOD_WARNING"
+ @modinfo -b ${INSTALL_MOD_PATH} ip_set_hash_ip | ${GREP} /extra/ >/dev/null || echo "$$DEPMOD_WARNING"
@lsmod | ${GREP} '^ip_set' >/dev/null && echo "$$MODULE_WARNING"
else
@echo Skipping kernel modules due to --with-kmod=no