summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0167374..b7b69d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -211,9 +211,10 @@ AC_MSG_CHECKING([kernel source for system_power_efficient_wq])
if test -f $ksourcedir/include/linux/workqueue.h && \
$GREP -q 'system_power_efficient_wq' $ksourcedir/include/linux/workqueue.h; then
AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_SYSTEM_POWER_EFFICIENT_WQ, define)
else
AC_MSG_RESULT(no)
- AC_MSG_ERROR([Kernel source tree is too old, at least v3.11 is required])
+ AC_SUBST(HAVE_SYSTEM_POWER_EFFICIENT_WQ, undef)
fi
AC_MSG_CHECKING([kernel source for struct xt_action_param])