summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c818557..26883d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -560,8 +560,8 @@ else
fi
AC_MSG_CHECKING([kernel source for passing extended ACK struct to parsing functions])
-if test -f $ksourcedir/include/linux/netlink.h && \
- $AWK '/^static inline int nla_parse_nested/ {for(i=1; i<=4; i++) {getline; print}}' $ksourcedir/include/linux/netlink.h | $GREP -q 'struct netlink_ext_ack'; then
+if test -f $ksourcedir/include/net/netlink.h && \
+ $AWK '/^static inline int nla_parse_nested/ {for(i=1; i<=4; i++) {getline; print}}' $ksourcedir/include/net/netlink.h | $GREP -q 'struct netlink_ext_ack'; then
AC_MSG_RESULT(yes)
AC_SUBST(HAVE_PASSING_EXTENDED_ACK_TO_PARSERS, define)
else
@@ -569,6 +569,16 @@ else
AC_SUBST(HAVE_PASSING_EXTENDED_ACK_TO_PARSERS, undef)
fi
+AC_MSG_CHECKING([kernel source for passing extended ACK struct to callback functions])
+if test -f $ksourcedir/include/linux/netfilter/nfnetlink.h && \
+ $AWK '/^struct nfnl_callback / {for(i=1; i<=5; i++) {getline; print}}' $ksourcedir/include/linux/netfilter/nfnetlink.h | $GREP -q 'struct netlink_ext_ack'; then
+ AC_MSG_RESULT(yes)
+ AC_SUBST(HAVE_PASSING_EXTENDED_ACK_TO_CALLBACKS, define)
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST(HAVE_PASSING_EXTENDED_ACK_TO_CALLBACKS, undef)
+fi
+
AC_MSG_CHECKING([kernel source for struct net_generic])
if test -f $ksourcedir/include/net/netns/generic.h && \
$GREP -q 'struct net_generic' $ksourcedir/include/net/netns/generic.h; then