summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-09-18 15:06:05 +0200
committerJan Engelhardt <jengelh@medozas.de>2011-09-19 13:42:32 +0200
commit8816e91cddef785c78b3598c7c41a1f88be08f5a (patch)
treed15e6d27f9c39c1d9a4004c40803bb67ccb72a9c /Makefile.am
parent1e4965232d77ab752c9c781afcf854f4b173c7b1 (diff)
build: restore build order of modules
iptables(exe) requires libext.a, but extensions/ require libxtables.la (in iptables/). This circular dependency does not work out, so separate libxtables into its own directory and put it in front. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9167e8e3..4eb63ebe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@
ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = foreign subdir-objects
-SUBDIRS = libiptc iptables
+SUBDIRS = libiptc libxtables
if ENABLE_DEVEL
SUBDIRS += include
endif
@@ -13,7 +13,10 @@ endif
if HAVE_LIBNFNETLINK
SUBDIRS += utils
endif
+# Depends on libxtables:
SUBDIRS += extensions
+# Depends on extensions/libext.a:
+SUBDIRS += iptables
.PHONY: tarball
tarball: