summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2009-04-03 22:28:34 +0200
committerJan Engelhardt <jengelh@medozas.de>2009-04-03 22:29:39 +0200
commit8e58613df53f5f83e8ab92dec61d8065c68d967d (patch)
tree986e3cc677f64613066d1fe951894ccdf8759ede /Makefile.am
parentc7f70f1b16ac9395bb13d1832b5c83b09594224f (diff)
build: add configure option to disable ip6tables
This also skips building the IPv6 extensions. It does not #ifdef out all code however, I think that would make it too ugly. Inspired-by: http://bugzilla.netfilter.org/show_bug.cgi?id=560 Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 30994746..a6b726c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,11 +85,16 @@ man_MANS = iptables.8 iptables-restore.8 iptables-save.8 \
CLEANFILES = iptables.8 ip6tables.8
if ENABLE_STATIC
-sbin_PROGRAMS += iptables-static ip6tables-static
+sbin_PROGRAMS += iptables-static
+if ENABLE_IPV6
+sbin_PROGRAMS += ip6tables-static
+endif
endif
if ENABLE_SHARED
-sbin_PROGRAMS += iptables iptables-multi iptables-restore iptables-save \
- ip6tables ip6tables-multi ip6tables-restore ip6tables-save
+sbin_PROGRAMS += iptables iptables-multi iptables-restore iptables-save
+if ENABLE_IPV6
+sbin_PROGRAMS += ip6tables ip6tables-multi ip6tables-restore ip6tables-save
+endif
endif
iptables.8: ${srcdir}/iptables.8.in extensions/matches4.man extensions/targets4.man