summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2009-04-03 22:37:49 +0200
committerJan Engelhardt <jengelh@medozas.de>2009-04-03 22:37:49 +0200
commita094eb0f2a57592b6f3cf42fdbb9d49fead2d57c (patch)
tree96763d59773cea7ae548a7528f203dae86fbd24d /Makefile.am
parent8e58613df53f5f83e8ab92dec61d8065c68d967d (diff)
build: add configure option to disable ipv4 iptables
This patch complements the previous one. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a6b726c5..fd99098f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,13 +85,17 @@ man_MANS = iptables.8 iptables-restore.8 iptables-save.8 \
CLEANFILES = iptables.8 ip6tables.8
if ENABLE_STATIC
+if ENABLE_IPV4
sbin_PROGRAMS += iptables-static
+endif
if ENABLE_IPV6
sbin_PROGRAMS += ip6tables-static
endif
endif
if ENABLE_SHARED
+if ENABLE_IPV4
sbin_PROGRAMS += iptables iptables-multi iptables-restore iptables-save
+endif
if ENABLE_IPV6
sbin_PROGRAMS += ip6tables ip6tables-multi ip6tables-restore ip6tables-save
endif