summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlorian Westphal <fw@strlen.de>2013-05-06 21:07:38 +0200
committerFlorian Westphal <fw@strlen.de>2013-05-06 21:07:38 +0200
commitccbf6b6448a4210432b76fd4660798705b05f8c4 (patch)
treef41c1d1b789dd50d77c4570b841db4cfc3506fd3 /Makefile.am
parentca376fcbe51b9a102a490545957d5fee69e253e1 (diff)
extensions: add connlabel match
allows to "tag" connections with up to 128 label names. Labels are defined in /etc/xtables/connlabel.conf, example: 0 from eth0 1 via eth0 Labels can then be attached to flows, e.g. -A PREROUTING -i eth0 -m connlabel --label "from eth0" --set Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cd008a19..931c565f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,5 +28,9 @@ install-data-hook:
@mkdir -p -m 755 $(DESTDIR)/etc/xtables/ || :
@test -f /etc/xtables/connlabel.conf || $(INSTALL) -m 644 etc/xtables/connlabel.conf $(DESTDIR)/etc/xtables/connlabel.conf || :
+install-data-hook:
+ @mkdir -p -m 755 $(DESTDIR)/etc/xtables/ || :
+ @test -f /etc/xtables/connlabel.conf || $(INSTALL) -m 644 etc/xtables/connlabel.conf $(DESTDIR)/etc/xtables/connlabel.conf || :
+
config.status: extensions/GNUmakefile.in \
include/xtables-version.h.in include/iptables/internal.h.in