summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlorian Westphal <fw@strlen.de>2013-05-06 21:01:38 +0200
committerFlorian Westphal <fw@strlen.de>2013-05-06 21:03:17 +0200
commitca376fcbe51b9a102a490545957d5fee69e253e1 (patch)
tree39d735bb98c642e6245452ade5ca0ab71151212d /Makefile.am
parentb5c12f4aa3ebfc4dac37799e41616c37c188ab4f (diff)
extensions: add connlabel match
allows to "tag" connections with up to 128 label names. Labels are defined in /etc/xtables/connlabel.conf, example: 0 from eth0 1 via eth0 Labels can then be attached to flows, e.g. -A PREROUTING -i eth0 -m connlabel --label "from eth0" --set Signed-off-by: Florian Westphal <fw@strlen.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c38d3600..cd008a19 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,5 +24,9 @@ tarball:
tar -C /tmp -cjf ${PACKAGE_TARNAME}-${PACKAGE_VERSION}.tar.bz2 --owner=root --group=root ${PACKAGE_TARNAME}-${PACKAGE_VERSION}/;
rm -Rf /tmp/${PACKAGE_TARNAME}-${PACKAGE_VERSION};
+install-data-hook:
+ @mkdir -p -m 755 $(DESTDIR)/etc/xtables/ || :
+ @test -f /etc/xtables/connlabel.conf || $(INSTALL) -m 644 etc/xtables/connlabel.conf $(DESTDIR)/etc/xtables/connlabel.conf || :
+
config.status: extensions/GNUmakefile.in \
include/xtables-version.h.in include/iptables/internal.h.in