summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMaciej Żenczykowski <zenczykowski@gmail.com>2011-06-06 18:27:09 -0700
committerJan Engelhardt <jengelh@medozas.de>2011-06-07 11:29:01 +0200
commit4598ed7d3e22d74ffaad7948ddc3455ac9aa7576 (patch)
tree8f23adfa0cb248615ac49c8e6e49a68791303050 /Makefile.am
parenta1cd1f2a4a35427c68cd0d1bd2761d5be42b12b1 (diff)
xtables-multi: fix absence of xml translator in IPv6-only builds
Commit v1.4.11-4-gde791ff did not actually build the iptables-xml code into the xtables-multi binary. Signed-off-by: Maciej Zenczykowski <maze@google.com> Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 60ea83b1..48f01d81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,7 +38,7 @@ libxtables_la_CFLAGS = ${AM_CFLAGS} -DNO_SHARED_LIBS=1
libxtables_la_LIBADD =
endif
-xtables_multi_SOURCES = xtables-multi.c
+xtables_multi_SOURCES = xtables-multi.c iptables-xml.c
xtables_multi_CFLAGS = ${AM_CFLAGS} -DIPTABLES_MULTI
xtables_multi_LDFLAGS = -rdynamic
xtables_multi_LDADD = extensions/libext.a
@@ -46,7 +46,7 @@ if ENABLE_STATIC
xtables_multi_CFLAGS += -DALL_INCLUSIVE
endif
if ENABLE_IPV4
-xtables_multi_SOURCES += iptables-save.c iptables-restore.c iptables-xml.c \
+xtables_multi_SOURCES += iptables-save.c iptables-restore.c \
iptables-standalone.c iptables.c
xtables_multi_CFLAGS += -DENABLE_IPV4
xtables_multi_LDADD += libiptc/libip4tc.la extensions/libext4.a