summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorShivani Bhardwaj <shivanib134@gmail.com>2016-06-20 23:06:34 +0530
committerPablo Neira Ayuso <pablo@netfilter.org>2016-06-22 14:39:49 +0200
commit4dd742ed19840490c59b85fa1ac4eb0510a8c78f (patch)
tree7fc9067942c43446994f4d0f814b91496fc40f7e /configure.ac
parent5d7cbf6e6c66d20129320a9b57ce56c868542816 (diff)
configure: Remove flex check warning
Remove the warning about outdated version of flex as it is not needed anymore. This check was introduced back in 2008 to skip a broken flex version that doesn't seem to be packaged by any distribution anymore. Signed-off-by: Shivani Bhardwaj <shivanib134@gmail.com> Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index b170addf..c91e9e71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,21 +157,6 @@ if test "x$enable_nftables" = "xyes"; then
echo " Please install the 'flex' package."
exit 1
fi
-
- AC_MSG_CHECKING(flex version)
- flex_version=`$ac_cv_prog_LEX --version | sed 's/version//g' | awk '/flex/ {print $2}'`
- flex_major=`echo $flex_version| cut -d . -f 1`
- flex_minor=`echo $flex_version| cut -d . -f 2`
- flex_rev=`echo $flex_version| cut -d . -f 3`
-
- if test "$flex_major" -eq "2" && test "$flex_minor" -eq "5" && test "$flex_rev" -ge "33"; then
- AC_MSG_RESULT([$flex_version. OK])
- else
- AC_MSG_WARN([flex version $flex_version found.
- Version 2.5.33 or greater is required. You may experience problems
- while compilating the nftables compatibility layer for iptables.
- Please, consider to upgrade flex.])
- fi
fi
AM_CONDITIONAL([HAVE_LIBMNL], [test "$mnl" = 1])