summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2009-04-03 22:37:49 +0200
committerJan Engelhardt <jengelh@medozas.de>2009-04-03 22:37:49 +0200
commita094eb0f2a57592b6f3cf42fdbb9d49fead2d57c (patch)
tree96763d59773cea7ae548a7528f203dae86fbd24d /configure.ac
parent8e58613df53f5f83e8ab92dec61d8065c68d967d (diff)
build: add configure option to disable ipv4 iptables
This patch complements the previous one. Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eefcdac9..152ad592 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,9 @@ AC_ARG_WITH([xtlibdir],
[Path where to install Xtables extensions [[LIBEXECDIR/xtables]]]),
[xtlibdir="$withval"],
[xtlibdir="${libexecdir}/xtables"])
+AC_ARG_ENABLE([ipv4],
+ AS_HELP_STRING([--disable-ipv4], [Do not build iptables]),
+ [enable_ipv4="$enableval"], [enable_ipv4="yes"])
AC_ARG_ENABLE([ipv6],
AS_HELP_STRING([--disable-ipv6], [Do not build ip6tables]),
[enable_ipv6="$enableval"], [enable_ipv6="yes"])
@@ -54,6 +57,7 @@ AC_SUBST([blacklist_modules])
AM_CONDITIONAL([ENABLE_STATIC], [test "$enable_static" = "yes"])
AM_CONDITIONAL([ENABLE_SHARED], [test "$enable_shared" = "yes"])
+AM_CONDITIONAL([ENABLE_IPV4], [test "$enable_ipv4" = "yes"])
AM_CONDITIONAL([ENABLE_IPV6], [test "$enable_ipv6" = "yes"])
AM_CONDITIONAL([ENABLE_DEVEL], [test "$enable_devel" = "yes"])
AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" = "yes"])