summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2011-06-24 20:16:48 +0200
committerJan Engelhardt <jengelh@medozas.de>2011-06-24 20:16:48 +0200
commit3c871010888e1479ef8fca2048485b979ec2661a (patch)
tree3fdeb43f3321ff04d2a2ca201326bb2fde0c6f62 /configure.ac
parent447ddfbfb3ed16ad0059f4559334670e9b9806ec (diff)
build: attempt to fix building under Linux 2.4
iptables no longer compiles for Linux 2.4 because it uses linux/magic.h. This header and the PROC_SUPER_MAGIC macro are only for Linux 2.6. xtables.c:35:52: error: linux/magic.h: No such file or directory xtables.c: In function 'proc_file_exists': xtables.c:389: error: 'PROC_SUPER_MAGIC' undeclared (first use in this function) xtables.c:389: error: (Each undeclared identifier is reported only once for each function it appears in.) References: http://bugzilla.netfilter.org/show_bug.cgi?id=720 Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b57f542d..6c90caaf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,12 +59,10 @@ AC_SUBST([libiptc_LDFLAGS2])
blacklist_modules="";
-AC_CHECK_HEADER([linux/dccp.h])
+AC_CHECK_HEADERS([linux/dccp.h linux/ip_vs.h linux/magic.h linux/proc_fs.h])
if test "$ac_cv_header_linux_dccp_h" != "yes"; then
blacklist_modules="$blacklist_modules dccp";
fi;
-
-AC_CHECK_HEADER([linux/ip_vs.h])
if test "$ac_cv_header_linux_ip_vs_h" != "yes"; then
blacklist_modules="$blacklist_modules ipvs";
fi;