summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2008-06-23 11:37:08 +0200
committerPatrick McHardy <kaber@trash.net>2008-06-23 11:37:08 +0200
commitee3228af38ec98c60a3b6f72a9b1c75b5ef53641 (patch)
tree09be5067f4a72ccd204e1e25ba55cababfc269dd /configure.ac
parenteaf831efecf936cab9a30f67284de7def4325545 (diff)
build: change equailty test for old bash
Michael used GNU bash, version 1.14.7(1), which apparently does not seem to know about the double ("==") variant of equality tests. Reported-by: Michael Teicher <mteicher@gmail.com> Signed-off-by: Jan Engelhardt <jengelh@medozas.de> Signed-off-by: Patrick McHardy <kaber@trash.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ce26e28c..2d2f90fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,10 +47,10 @@ if test "$ac_cv_header_linux_dccp_h" != "yes"; then
fi;
AC_SUBST([blacklist_modules])
-AM_CONDITIONAL([ENABLE_STATIC], [test "$enable_static" == "yes"])
-AM_CONDITIONAL([ENABLE_SHARED], [test "$enable_shared" == "yes"])
-AM_CONDITIONAL([ENABLE_DEVEL], [test "$enable_devel" == "yes"])
-AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" == "yes"])
+AM_CONDITIONAL([ENABLE_STATIC], [test "$enable_static" = "yes"])
+AM_CONDITIONAL([ENABLE_SHARED], [test "$enable_shared" = "yes"])
+AM_CONDITIONAL([ENABLE_DEVEL], [test "$enable_devel" = "yes"])
+AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" = "yes"])
regular_CFLAGS="-D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 \
-D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations \