summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2010-09-13 16:06:50 +0200
committerJan Engelhardt <jengelh@medozas.de>2010-09-13 23:42:56 +0200
commit655ae6b096b7ba3854159dc1eefadce91ec65550 (patch)
treee79a15fd586f3f818c33bbf8b2faa68ac8c09f4d /configure.ac
parent5429b41c2bb4ac8fe672a1513a041c0ed0c241f6 (diff)
libiptc: build with -Wl,--no-as-needed
Since libiptc does not reference any symbols in libip(4|6)tc, the linker may ignore the dependencies. Use --no-as-needed to explicitly force a DT_NEEDED entry. References: http://bugzilla.netfilter.org/show_bug.cgi?id=674 Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b26f548..6010afd6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,11 @@ AC_ARG_WITH([pkgconfigdir], AS_HELP_STRING([--with-pkgconfigdir=PATH],
[Path to the pkgconfig directory [[LIBDIR/pkgconfig]]]),
[pkgconfigdir="$withval"], [pkgconfigdir='${libdir}/pkgconfig'])
+libiptc_LDFLAGS2="";
+AX_CHECK_LINKER_FLAGS([-Wl,--no-as-needed],
+ [libiptc_LDFLAGS2="-Wl,--no-as-needed"])
+AC_SUBST([libiptc_LDFLAGS2])
+
blacklist_modules="";
AC_CHECK_HEADER([linux/dccp.h])