summaryrefslogtreecommitdiffstats
path: root/iptables/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2014-06-13 11:40:41 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2014-06-13 12:05:58 +0200
commit03a3f7cf1826f70dd1db070aa8ee11bd2abbccd9 (patch)
tree15e51d52846ef0dd111a6e9b46d8b10232a0ae6c /iptables/Makefile.am
parenta2a3eb1393b5c37881a355d1e714bdc9c87fe7cf (diff)
Makefile: fix static compilation iptables-compat without shared libraries
Fix linking problems when this configuration is used: $ ./configure --prefix=/usr --enable-shared=no --enable-static=yes $ make ... xtables_compat_multi-xtables-save.o: In function `xtables_save_main': /home/pablo/devel/iptables/iptables/xtables-save.c:98: undefined reference to `init_extensions4' xtables_compat_multi-xtables-restore.o: In function `xtables_restore_main': /home/pablo/devel/iptables/iptables/xtables-restore.c:195: undefined reference to `init_extensions4' xtables_compat_multi-xtables-standalone.o: In function `xtables_main': /home/pablo/devel/iptables/iptables/xtables-standalone.c:61: undefined reference to `init_extensions4' xtables_compat_multi-xtables-events.o: In function `xtables_events_main': /home/pablo/devel/iptables/iptables/xtables-events.c:184: undefined reference to `init_extensions4' Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'iptables/Makefile.am')
-rw-r--r--iptables/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index 41bca7c7..aaaade85 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -40,7 +40,7 @@ xtables_compat_multi_SOURCES += xtables-save.c xtables-restore.c \
nft-shared.c nft-ipv4.c nft-ipv6.c nft-arp.c \
xtables-config.c xtables-events.c \
xtables-arp-standalone.c xtables-arp.c
-xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS}
+xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ../extensions/libext4.a ../extensions/libext6.a
# yacc and lex generate dirty code
xtables_compat_multi-xtables-config-parser.o xtables_compat_multi-xtables-config-syntax.o: AM_CFLAGS += -Wno-missing-prototypes -Wno-missing-declarations -Wno-implicit-function-declaration -Wno-nested-externs -Wno-undef -Wno-redundant-decls
xtables_compat_multi_SOURCES += xshared.c